Basically I need to remove index.php or public/index.php from the the generated URL in laravel, commonly path is localhost/public/index.php/someWordForRoute, It should be something like localhost/someWordForRoute

htacces

<IfModule mod_rewrite.c>
<IfModule mod_negotiation.c>
Options -MultiViews
</IfModule>

RewriteEngine On

# Redirect Trailing Slashes...
RewriteRule ^(.*)/$ /$1 [L,R=301]

# Handle Front Controller...
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^ index.php[L]

app/config/app.php

'url' => 'http://localhost',

how can I change that?

7 upvote
  flag
Pretty URLs in Laravel. Make sure mod_rewrite is enabled. – Kryten
1 upvote
  flag
upvote
  flag
@Kryten doesnt work =/ – cheloncio
2 upvote
  flag
This is the solution when the other solution doen't work dev-metal.com/enable-mod_rewrite-ubuntu-14-04-lts – cheloncio
upvote
  flag
Is your document root pointing at the intended folder, i.e /var/www/project_name/public – Kiee
upvote
  flag
or you could try moving the files too like this: youtu.be/ybJYyU5FPv4 – MD Singh

14 Answers 11

Laravel ships with a pretty URL .htaccess already... you should be good to go out of the box... http://laravel.com/docs/installation#pretty-urls

Make sure mod_rewrite is enabled and that your home path is set to the public directory of your application.

upvote
  flag
I activaded mod_rewrite and I copied the code that's on that page and still without works – cheloncio
1 upvote
  flag
Make sure in Apache your path is set to the public folder of your application. – Kisuka
upvote
  flag
ServerAdmin webmaster@localhost DocumentRoot /home/web-apps/myproject/public – cheloncio
upvote
  flag
Did you restart apache after enabling mod_rewrite? – Kisuka
upvote
  flag
I have a folder called user is the place where I keep photos, also I have a blade file called user , when I write in the URL myproject.com/user shows me the contents of the folder, the pictures – cheloncio

I tried this on Laravel 4.2

Rename the server.php in the your Laravel root folder to index.php and copy the .htaccess file from /public directory to your Laravel root folder.

I hope it works

1 upvote
  flag
If the accepted answer by Luazan doesn't work then this will suffice. Although I would make sure to edit the index.php file in the public folder to redirect users out of public if they go straight to that link. – Brad Bird
4 upvote
  flag
The js and css files are not loaded anymore from public folder – llioor
1 upvote
  flag
not secure..... – MaHDyfo

1) Check whether mod_rewrite is enabled. Go to /etc/apache2/mods-enabled directory and see whether the rewrite.load is available. If not, enable it using the command sudo a2enmod rewrite.It will enable the rewrite module. If its already enabled, it will show the message Module rewrite already enabled.
2)Create a virtual host for public directory so that instead of giving http://localhost/public/index.php we will be able to use like that http://example.com/index.php. [hence public folder name will be hidded]
3)Then create a .htaccess which will hide the index.php from your url which shoul be inside the root directory (public folder)

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ /index.php?/$1 [L]
upvote
  flag
Tried your steps. Got no result yet! I don't why is this happening! – mostafiz rahman
upvote
  flag
Give the log info so that we can trace the root cause – Orchid
upvote
  flag
upvote
  flag
worked for me. Dont make the virtual host go straight to the public folder. – cardi777
upvote
  flag
Thank you. This worked for me, my mod_rewrite was disabled. – Maubeh

This likely has very little to do with Laravel and everything to do with your Apache configs.

Do you have access to your Apache server config? If so, check this out, from the docs:

In general, you should only use .htaccess files when you don't have access to the main server configuration file. There is, for example, a common misconception that user authentication should always be done in .htaccess files, and, in more recent years, another misconception that mod_rewrite directives must go in .htaccess files. This is simply not the case. You can put user authentication configurations in the main server configuration, and this is, in fact, the preferred way to do things. Likewise, mod_rewrite directives work better, in many respects, in the main server configuration.

... In general, use of .htaccess files should be avoided when possible. Any configuration that you would consider putting in a .htaccess file, can just as effectively be made in a section in your main server configuration file.

Source: Apache documentation.

The reason why I mention this first is because it is best to get rid of .htaccess completely if you can,and use a Directory tag inside a VirtualHost tag. That being said, the rest of this is going to assume you are sticking with the .htaccess route for whatever reason.

To break this down, a couple things could be happening:

  1. I note, perhaps pointlessly, that your file is named .htacces in your question. My guess is that it is a typo but on the off chance you overlooked it and it is in fact just missing the second s, this is exactly the sort of minor error that would leave me banging my head against the wall looking for something more challenging.

  2. Your server could not be allowing .htaccess. To check this, go to your Apache configuration file. In modern Apache builds this is usually not in one config file so make sure you're using the one that points to your app, wherever it exists. Change

    AllowOverride none
    

    to

    AllowOverride all
    

    As a followup, the Apache documents also recommend that, for security purposes, you don't do this for every folder if you are going to go for .htaccess for rewriting. Instead, do it for the folders you need to add .htaccess to.

  3. Do you have mod_rewrite enabled? That could be causing the issues. I notice you have the tag at the top <IfModule mod_rewrite.c>. Try commenting out those tags and restart Apache. If you get an error then it is probably because you need to enable mod_rewrite: How to enable mod_rewrite for Apache 2.2

Hope this helps. I've named some of the most common issues but there are several others that could be more mundane or unique. Another suggestion on a dev server? Re-install Apache. If possible, do so from a different source with a good tutorial.

upvote
  flag
AllowOverride all works for me! – Cristian Sepulveda
up vote 86 down vote accepted

Option 1: Use .htaccess

If it isn't already there, create an .htaccess file in the Laravel root directory. Create a .htaccess file your Laravel root directory if it does not exists already. (Normally it is under your public_html folder)

Edit the .htaccess file so that it contains the following code:

<IfModule mod_rewrite.c>
   RewriteEngine On 
   RewriteRule ^(.*)$ public/$1 [L]
</IfModule>

Now you should be able to access the website without the "/public/index.php/" part.

Option 2 : Move things in the '/public' directory to the root directory

Make a new folder in your root directory and move all the files and folder except public folder. You can call it anything you want. I'll use "laravel_code".

Next, move everything out of the public directory and into the root folder. It should result in something somewhat similar to this: enter image description here

After that, all we have to do is edit the locations in the laravel_code/bootstrap/paths.php file and the index.php file.

In laravel_code/bootstrap/paths.php find the following line of code:

'app' => __DIR__.'/../app',
'public' => __DIR__.'/../public',

And change them to:

'app' => __DIR__.'/../app',
'public' => __DIR__.'/../../',

In index.php, find these lines:

require __DIR__.'/../bootstrap/autoload.php';     
$app = require_once __DIR__.'/../bootstrap/start.php';

And change them to:

require __DIR__.'/laravel_code/bootstrap/autoload.php';     
$app = require_once __DIR__.'/laravel_code/bootstrap/start.php';

Source: How to remove /public/ from URL in Laravel

4 upvote
  flag
If you use Debian Linux, don't forget to edit etc/apache2/apache2.conf changing from AllowOverride None to AllowOverride All where you see the Directory config, <Directory /var/www/></Directory> . – Robin Hood
1 upvote
  flag
I had only to had the .htaccess file to my root directory to get it working. – Mário Rodrigues
5 upvote
  flag
Moving to /root isn't a good advice at all in production mode! There's a reason why the public folder exists – toesslab.ch
upvote
  flag
To ensure the rewrite rules work check that the apache config <Directory ... config has AllowOverride All' Something like this: <Directory "/var/www/html/laravel/public"> Options Indexes FollowSymLinks MultiViews **AllowOverride All** </Directory> – Japheth Ongeri - inkalimeva
upvote
  flag
What if I have no conf access on hosting? – pbalazek
upvote
  flag
@Daenu What is purpose of public folder what problem will removing it will cause on production? – Simer
upvote
  flag
Hell no. Never ever do that. – Daniel Steiner
upvote
  flag
Along with above.htaccess code rename our server.php file from root to index.php. These both combinations worked for me. !! thank @Luzan. – Alankar More
upvote
  flag
@Luzan Baral I tried this but not working for me. Why not working in my Case. Created 5.2 Project as BondOnFire, giving the read write permissions to Storage folder, the welcome screen comes. Thn I run php artisan make:auth, it works. I create a Folder Bond in BondOnFire and put all the code in it except public folder. I take out all the code of public folder outside it in BondOnFire directory . Then changed the .htaccess file and restarted serve.when I click on "Register" on the right side of the home screen, it says requested URL not found. Can you please help, what am I missing. – Mukesh
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^(.*)/(public)/(index.php)/$ $1/$4 [L]
</IfModule>
3 upvote
  flag
Providesome more explanation to your solution – Naruto

HERE ARE SIMPLE STEPS TO REMOVE PUBLIC IN URL (Laravel 5)

1: Copy all files form public folder and past them in laravel root folder

2: Open index.php and change

From

 require __DIR__.'/../bootstrap/autoload.php';

To

 require __DIR__.'/bootstrap/autoload.php';

And

$app = require_once __DIR__.'/../bootstrap/app.php';

To

$app = require_once __DIR__.'/bootstrap/app.php';

In laravel 4 path 2 is $app = require_once __DIR__.'/bootstrap/start.php'; instead of $app = require_once __DIR__.'/bootstrap/app.php';/app.php

That is it.

upvote
  flag
Are there any other complications regarding other linking from the site? – Haring10
upvote
  flag
That looks like a great solution and simple also. But really, as Haring10 said. Are there any issues with this? – pbalazek
upvote
  flag
great solution. easily solve my problem.thanks – Masum billah

Don't get confused with other option the snippet below I am using and will be useful for you too. Put the below htacces in your root.

<IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteRule    ^$    public/    [L]
    RewriteRule    (.*) public/$1    [L]
</IfModule>

Go to your public directory and put another htaccess file with the code snippet below

<IfModule mod_rewrite.c>
    RewriteEngine On
    # Removes index.php from ExpressionEngine URLs  
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?url=$1 [PT,L]

</IfModule>

Its working... !!!

upvote
  flag
Great: can you tell me what are pros and cons of this method? – Muhammad Ateek
 RewriteEngine on

 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteCond %{REQUEST_FILENAME} !-d

 RewriteRule ^(.*)$ index.php/$1 [L]

use this in .htaccess and restart the server

Hope this helps like it did for me.

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_URI} !^public
RewriteRule ^(.*)$ public/$1 [L]
</IfModule>

Rename the server.php in the your Laravel root folder to index.php and copy the .htaccess file from /public directory to your Laravel root folder. -- Thats it !! :)

I just installed Laravel 5 for a project and there is a file in the root called server.php. Just change it to index.php and it works or in terminal, type

$cp server.php index.php

As per Laravel 5.3 the above things will not work properly, but please be calm and follow below steps:

Step 1. Go to inside of laravel project
Step 2. Make one random directory/folder eg. laravelcode
Step 3. Move all the folder and files(Except public folder)
Step 4. Move all the folder and files which are inside the public folder to the laravel project
Step 5. Now inside the laravel project there is index.php file, please open that and change the folder paths for bootstrap as per new path like previously it was "require DIR.'/../bootstrap/autoload.php';" now it will become to "require DIR.'/laravelcode/bootstrap/autoload.php';"

That's it just run your url without public and index.php like below http://localhost/blog/

For Laravel 4 & 5:

  1. Rename server.php in your Laravel root folder to index.php
  2. Copy the .htaccess file from /public directory to your Laravel root folder.

Thats it !! :)

Not the answer you're looking for? Browse other questions tagged or ask your own question.