All Questions

49
votes
13answers
69556 views

CakePHP 3.0 installation: intl extension missing from system

Using the CakePHP docs, I am trying to install 3.0-beta2 using composer but I got this error: cakephp/cakephp 3.0.x-dev requires ext-intl * -> the requested PHP extension intl is missing from y...
28
votes
5answers
21442 views

Why use a PSR-0 or PSR-4 autoload in composer if classmap is actually faster?

I understand that you can use either a PSR standard to locate files, or tell composer a directory to scan for classes. The documentation recommends using the PSR-4 standard. There is also an option fo...
102
votes
6answers
39069 views

How to require a fork with composer

here is my composer.json, i want to use Nodge's fork of lessphp project on Github "repositories": [{ "type": "package", "package": { "version": "dev-master", "name": "nodge/l...
127
votes
13answers
130568 views

Composer Warning: openssl extension is missing. How to enable in WAMP

Trying to install Composer dependency management tool on Win7/64 + WampServer 2.2 via the Setup Installer and I am getting the following message: The openssl extension is missing, which will reduc...
121
votes
11answers
138026 views

You must enable the openssl extension to download files via https

I wanted to install Zend Framework 2. So I downloaded the skeleton application. As mentioned in the ZF2 manual, we have to issue the command php composer.phar install Inside the skeleton. But I...
142
votes
3answers
35577 views

What is the difference between PSR-0 and PSR-4?

I've recently read about namespaces and how they are beneficial. I'm creating a project in Laravel and was trying to move from class map autoloading to namespacing. I can't seem to grasp what the a...
22
votes
6answers
20640 views

Run composer with a PHP script in browser

Wondering if it's possible to execute composer from the browser with a little PHP wrapper as I don't have access to shell access to the server. Not sure if you can do this with cURL?
22
votes
9answers
70045 views

PHP Composer behind http proxy

I use composer on a network where the only way to access the internet is using HTTP or socks proxy. I have http_proxy and https_proxy environment variables. When compose tries to access HTTPS URLs I g...
375
votes
6answers
78935 views

Should composer.lock be committed to version control?

I'm a little confused with composer.lock used in an application with a repository. I saw many people saying that we should not .gitignore composer.lock from the repository. If I update my libraries ...
106
votes
18answers
189204 views

How to enable PHP's openssl extension to install Composer?

I am trying to install Laravel in WAMP setup. I am getting a warning message for not enabling openssl which I had already done in WAMP. Here is a screenshot of the message.

Previous Next